[Dxspider-support] Frustration lock out of sysop mode

Dirk Koopman G1TLH gb7tlh at dxcluster.org
Sat Oct 9 11:36:37 BST 2010

On 09/10/10 11:11, Keith wrote:
> Hi Group
> I need some help here please
> Last night I carried out a git update to the Dxcluster here and now I
> can't logon as sysop. Dxcluster is running fine can connect as an
> ordinary use but not with sysop privileges.

A git update will not have forced a new password onto anyone, let alone 
the sysop. There have been no updates on password related matters for 
several years. The latest update (assuming that you have kept up to date 
since June) only concerned installing the latest prefix data.

Have you tried "telnet localhost 7300" with the callsign set in 
DXVars.pm as $myalias? Does it ask for a password then? Obviously, you 
would need to do that in a shell or command window on the cluster node 
box itself.

> How can I reset the sysop password?
> I have tuned off the password requirement in the start script and
> restarted the cluster
> but still get asked for the sysop password. I have tried all the tricks
> that I can think of.

It has always been the case (by design) that if you login with the sysop 
($myalias) callsign from outside the cluster node machine that you would 
only get normal user privileges (and that isn't about to change).

The only ways to get sysop privileges are to:

a) login on the node machine itself
b) login with a password via a TCP connection from outside the node box
c) login from outside (via TCP or AX25) and then use the "sysop" command.

There is a nuclear option: which is to edit your latest user_asc file, 
find your $myalias callsign entry, remove any "passwd => 'xxx'" or 
"passphrase => 'yyy'" on there, save the file. stop the node, execute 
"perl user_asc", restart the node.


More information about the Dxspider-support mailing list